Quick Tip – Error Installing Exchange – “this user isn’t a member of the ‘Schema/Enterprise Admins’ groups.”

We have run into an issue several times at customers when preparing for a Microsoft Exchange installation, and thought it would be good to share!

When installing Exchange, whether that be an upgrade or a brand new install, the account you use for the installation needs to have Enterprise Admin and/or Schema Admin group membership. Having ensured that this membership is assigned, you can often find you still receive the following error when trying to extend the Exchange Schema:

The Active Directory schema isn't up-to-date, and this user account isn't a member of the 'Schema Admins' and/or 'Enterprise Admins' groups.

This error is in complete contradiction to what we know to be true, however, when checking the account in Active Directory we have noticed that the Primary Group was still set to Domain Users (see below)

powershell

If you set the Enterprise Admin or Schema Admin group to the primary group by clicking the “Set Primary Group” button, then log off from the server and then log back in to update the group membership. The Pre-requisite checks should then pass without issue!

powershell2

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s